iDevGames Forums
OpenAL Freeze on ppc and i386 - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Graphics & Audio Programming (/forum-9.html)
+--- Thread: OpenAL Freeze on ppc and i386 (/thread-1501.html)



OpenAL Freeze on ppc and i386 - AdrianM - Apr 4, 2009 04:33 PM

I'm writing a breakout clone for mac and i'm having some troubles with OpenAl. Every once in a while it freezes at alSourceStop . Here's a pic from the debugger:

[img=http://img4.imageshack.us/img4/8893/picture2etc.th.png]

I'm using the OpenAl framework from /System/Library/Frameworks and the OpenAl binary from the framework is dated in 2007.


OpenAL Freeze on ppc and i386 - wadesworld - Apr 5, 2009 09:20 PM

It's been a while since I've looked at OpenAL and I'm pretty much pulling this out of my you-know-what. However, the first thing I'd look at given that stack trace is whether you're using/sharing OpenAL resources correctly. That stack trace appears to be waiting to acquire a lock on something. Presumably, for some reason, it can't. The question is, why not?

Again though, this is totally off the top of my head and based solely on one single screen shot. I could be *way* wrong. But given that limited amount of information, that's where I'd start looking if it were me.


OpenAL Freeze on ppc and i386 - AdrianM - Apr 7, 2009 04:27 AM

wadesworld Wrote:It's been a while since I've looked at OpenAL and I'm pretty much pulling this out of my you-know-what. However, the first thing I'd look at given that stack trace is whether you're using/sharing OpenAL resources correctly. That stack trace appears to be waiting to acquire a lock on something. Presumably, for some reason, it can't. The question is, why not?

Again though, this is totally off the top of my head and based solely on one single screen shot. I could be *way* wrong. But given that limited amount of information, that's where I'd start looking if it were me.

Well, the thing is that the same application works without problems on windows. I use OpenAl on windows too. I don't know how i could use openal resources wrong.

Does anyone know where i can get the latest svn version of openal? Because the svn seems to be down on svn:/connect.creativelabs.com/OpenAL