iDevGames Forums
OpenGL Extension Loading - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Graphics & Audio Programming (/forum-9.html)
+--- Thread: OpenGL Extension Loading (/thread-2462.html)



OpenGL Extension Loading - othello - Aug 12, 2008 11:00 PM

Hi

I'm having difficulties loading framebuffer object extensions using glext.h. It does not define the functions for some reason.

I'm using an ATI Radeon HD 2600, so I'm quite sure it has support for the extension.

I don't really have experience loading extensions on a mac; this is the first time I tried. On Windows it was relatively easy. I've tried using <OpenGL/glext.h>, <OpenGL/gl.h>, and a downloaded copy of glext from Khronos. None of them work.


OpenGL Extension Loading - OneSadCookie - Aug 13, 2008 12:42 AM

The system glext.h should be just fine -- certainly on Leopard, and I'm pretty sure on Tiger with Xcode 2.4.1 or later; possibly earlier Xcode versions.

There's no "loading" to be done per se (no PFNGL rubbish), just include <OpenGL/glext.h> and call the functions.


OpenGL Extension Loading - othello - Aug 14, 2008 12:10 AM

Hmm... that's what I thought, but for some reason I get compiler errors saying that the functions are not defined. When I add an #error directive next to the function definitions in glext.h, it does not show up at all. The entire block of code does not seem to be included.


OpenGL Extension Loading - OneSadCookie - Aug 14, 2008 12:30 AM

Which SDK are you compiling against? They wouldn't be defined in the 10.3.9 SDK...

If you don't know, paste your detailed build log from Xcode...


OpenGL Extension Loading - othello - Aug 14, 2008 01:52 AM

I'm pretty sure it's the latest; I'm using the normal OpenGL framework, and I'm running 10.5.4. I'll look more into it tomorrow. I'm gonna try and figure out which #if statement is returning false. I just wish glext wasn't 5000 lines of code.

I'm using SDL, but I don't believe that should make a difference.
Thanks, by the way.

P.S. GL_EXT_framebuffer_object is defined, just not the gl functions...


OpenGL Extension Loading - OneSadCookie - Aug 14, 2008 01:59 PM

Did you #define GL_GLEXT_FUNCTION_POINTERS or something silly like that?