iDevGames Forums
SDL_image + libpng + Panther = version mismatch - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Graphics & Audio Programming (/forum-9.html)
+--- Thread: SDL_image + libpng + Panther = version mismatch (/thread-4887.html)



SDL_image + libpng + Panther = version mismatch - BobbyWatson - Oct 22, 2005 06:53 PM

Hello everyone,

I'm currently trying to use SDL_image in a project, and I need PNG support. The project compiles fine, and SDL_image works fine with JPEG images, but when I try to load a PNG file, I get the following errors in the run log :

Code:
libpng warning: Application was compiled with png.h from libpng-1.0.12
libpng warning: Application  is  running with png.c from libpng-1.2.8
libpng error: Incompatible libpng version in application and library

I tried using the prepackaged installer from the libSDL website and linking with the framework located in /Library/Frameworks, but that didn't help.

I tried compiling my own version of the Frameworks with the source code and the supplied version of libpng.a that is included with the source, but I get the same error. I tried replacing this libpng.a file with a new one compiled with the libPNG source, but that doesn't help either.

I'm *guessing* that my app is not using the libpng.a file that comes with SDL_image, but the one installed on the system in /usr/local/lib.

Has anyone had this problem in the past? How was it resolved?

I'm running Panther 10.3.9 on a Mac mini, with XCode 1.5, by the way. Haven't tried on Tiger to see if I get the same error.


SDL_image + libpng + Panther = version mismatch - Malarkey - Oct 22, 2005 08:03 PM

Having you tried installing the libpng binaries you built? I.e., sudo make install from within the PNG source directory.


SDL_image + libpng + Panther = version mismatch - BobbyWatson - Oct 23, 2005 03:55 AM

I thought about it, but then once the game is done and I want someone to use it, this person would have to do the same on his/her system. I would think forcing the user to do a sudo make install is not the user-friendly way of running a game. I deally, the game would have to be a simple .app bundle working right out of the box...