iDevGames Forums
Weird GLUT problem - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Graphics & Audio Programming (/forum-9.html)
+--- Thread: Weird GLUT problem (/thread-7686.html)



Weird GLUT problem - Dracir - Jun 28, 2002 01:15 PM

I am using glutGameMode. I set up my rendering function via glutDisplayFunc(), and I go into glutMainLoop()óbut sometimes when I run it, the DisplayFunc is not getting called! At first I thought my rendering code was buggy, but then I used SysBeep() to figure out that GL isn't calling my rendering function in the first place. Sometimes it works, sometimes it doesn't. I tried reinstalling OpenGL and linking to a different glut.lib, but nothing helps. I am using system 9 with CodeWarrior IDE 4.04. Any ideas?

Thanks in advance!


Weird GLUT problem - OneSadCookie - Jun 28, 2002 01:57 PM

My recollection is that GLUT's game mode is only partially implemented on MacOS9. It's certainly severely lacking on MacOSX. Are you checking glutGameModeGet(GLUT_GAME_MODE_POSSIBLE) before glutEnterGameMode()?