iDevGames Forums
Crystal Space - not happening! - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Graphics & Audio Programming (/forum-9.html)
+--- Thread: Crystal Space - not happening! (/thread-7732.html)



Crystal Space - not happening! - griffin239 - May 30, 2002 06:43 AM

I've tried to download Crystal Space over CVS about 20 times..and its stops after some 5000+ files.
Leaving me with no CodeWarrior Projects and a lot of empty folders.

Attempting to add resources from CS to Codewarrior only gets me "can not be added messages"

Two emails to the Mac guys of the CS project has produced no reply.

Anyone have any luck with this thing?
It would appear to be an alternative to the commerical Torque engine, but without being able to do anything with it..thats hard to say.

Fill me in, what the hell am I missing?


Crystal Space - not happening! - codemattic - May 30, 2002 08:36 AM

I dont know why your cvs isnt working, but...

I believe that cs for Mac OS classic is dead. Its only Mac OSX - and right now I think they only have makefiles set up - and you can only launch cs from the command line in Terminal (its not a double-clickable app.) But once you get it to run - it goes like gangbusters.

Project Builder and double-clickable app capability is being worked on - but its been a long time coming. When they do get it running it will be sweet becuase the PB project files will be automatically generated - so the Mac OSX version will always be up to date with the rest of the ports.

Incidently - whenever Ive written to the Mac guys theyve written back.

cheers,
Codemattic


Crystal Space - not happening! - griffin239 - May 30, 2002 11:03 AM

Ok i'm new to this whole build a program from 5000 files thing.

So your saying to use project builder instead of Codewarrior?

Want to give me some steps to do this?
...I didn't see where this info was clearly defined...
as it would appear all the source sites and and such just expect you to be a programmer.

Is there some secret handshake and virgin sacrifice involved in this coding thing? If so..I already did all that to be a Mac user back in high school. Grin


Crystal Space - not happening! - codemattic - May 30, 2002 05:20 PM

Quote:Originally posted by griffin239
Ok i'm new to this whole build a program from 5000 files thing.

So your saying to use project builder instead of Codewarrior?

I wish. No Im saying that you will have to open up Terminal.app and "cd" to the directory with the make file. Run the configure makefile from the command line and then "make all." Its all very unixy brother! No GUI involved. It should be in the documentation. Its not hard. I will try and find the instructions and post them here. But I cant right now.

till then...,
Codemattic


Crystal Space - not happening! - griffin239 - May 30, 2002 06:19 PM

OK..I'll go back to the instructions and see what I missed..in the mean time enjoy this humor.
http://www.dslreports.com/forum/remark,3410990~root=deeplink~mode=flat

totaly off topic...but a laugh and a half..full 19 meg movie! ISP helpdesk....hilarious.


Crystal Space - not happening! - codemattic - May 31, 2002 12:11 AM

Griffin -

download the latest snapshot - or get the latest source off of cvs.
open terminal.app
'cd' into the cs directory. (hint - type cd <space> and then drag the cs folder onto the terminal.app window and terminal will enter the proper path name saving you the effort)
type 'make macosx'
wait a bit.
type 'make all'
go out and see a movie, get some dinner, take a long walk. When you come back it *probably* will be finished compiling.
type './walktest'
a window should open in the background. To bring it to the front make sure you click on the window's title bar - *not* in the window's content. If you click only in the window's content - that will bring it to the front - but keystrokes wil still be sent to Terminal.app and you wont be able to move around.

Also, in cs\data\config\ there are a bunch of config files that you can open up in a text editor. Make sure to open up the walktest.cfg and set the video driver to be the opengl one (unless you like running at 5fps and low-res textures!)

good luck,
Codemattic


Crystal Space - not happening! - stijnschoor - Apr 3, 2008 10:56 AM

thanks for the information. After all this compiling I've still got a problem. When I try to run a CS program it jumps in the Dock but after a while it just disappears. Can you help me?

In advanced thanks


Crystal Space - not happening! - AndyKorth - Apr 3, 2008 11:59 AM

Check the Console application for an error log. You'll probably find something helpful there.

Also, this thread is really old.


Crystal Space - not happening! - PowerMacX - Apr 3, 2008 10:40 PM

This must be some kind of record... a thread from 2002? Smile

You can find more info asking specifically in the CS support forum:
http://www.crystalspace3d.org/forum/index.php/board,2.0.html

Or searching there for Mac OS X related posts, for instance:
http://www.crystalspace3d.org/forum/index.php/topic,399.0.html