iDevGames Forums
will I be able to submit to the App store from OSX 10.5? - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: iPhone, iPad & iPod Game Development (/forum-11.html)
+--- Thread: will I be able to submit to the App store from OSX 10.5? (/thread-8894.html)



will I be able to submit to the App store from OSX 10.5? - aerospaceman - Apr 25, 2011 08:00 AM

I am developing on an older Macbook running OSX 10.5 and an older version of XCode.
The system requirements on the Apple page say OSX 10.6 Snow Leopard.
Will I still be able to submit my app?


RE: will I be able to submit to the App store from OSX 10.5? - Skorche - Apr 25, 2011 08:51 AM

No, you need a newish version of XCode in order to sign your app to send it off.


RE: will I be able to submit to the App store from OSX 10.5? - aerospaceman - Apr 25, 2011 11:24 AM

cool I ordered the 10.6 upgrade. I'm probably also going to upgrade the RAM from 512MB to 1GB.
Any other tips for making my first generation Macbook run faster?


RE: will I be able to submit to the App store from OSX 10.5? - OneSadCookie - Apr 25, 2011 11:40 AM

1GB is probably not enough for SL with integrated graphics, even on a 32-bit machine. Check if it can take 2GB.


RE: will I be able to submit to the App store from OSX 10.5? - Skorche - Apr 25, 2011 01:01 PM

RAM is about the only thing you can do. 1GB would work ok. I mean it would boot and you could run Xcode, but more would definitely be better.


RE: will I be able to submit to the App store from OSX 10.5? - aerospaceman - Apr 27, 2011 08:39 AM

I dunno if I'm gonna reach 1 GB, I think I'll have to replace one of the 256MB chips with the 512 I just ordered.
Xcode by iteself works fine, but any multitasking kills it right now.