iDevGames Forums
unable to load app with loader - Printable Version

+- iDevGames Forums (http://www.idevgames.com/forums)
+-- Forum: Development Zone (/forum-3.html)
+--- Forum: Game Programming Fundamentals (/forum-7.html)
+--- Thread: unable to load app with loader (/thread-9581.html)



unable to load app with loader - sefiroths - Nov 28, 2011 01:45 PM

i'm trying to submit my app, i have builded in simulator, then click on the xcode folder products, right click on myapp.app show in finder, zipped that file and used loader to upload.


but i receice this issues:
iphone/ipod touch: application executable is missing required architecture. at least one of the following must be present: armv6
>>but if i click on the project->targets in architecture i have standard(armv6 armv7)
icon dimension (58x58) don't meet the size requirements. the icon must be 57x57
>>the icon was 58x58, so i have made it 57x57 but still get this error

application failed codesign verification. the signature was invalid, or it was signed with an apple submission certificate
>>i made a new app store distribution profile and putted in code sign->debug but still this error occours

any ideas?
thanks


RE: unable to load app with loader - monteboyd - Nov 28, 2011 05:39 PM

You need to build for a device, not the simulator.


RE: unable to load app with loader - sefiroths - Nov 29, 2011 01:12 PM

builded to a device, and set to release
it solved the problem of icon and target archtecture, remain codesign

i have sett on codesign identity:
iphone developer: team provisioning profile
iphone distribution: myapp app store distribution

following this steps:
http://www.weston-fl.com/blog/?p=2442
i have armv6 error
but solved setting "build active architecture only" to "NO"