Has anyone tried audio file streaming with the ExtendedAudioFile APIs?

Member
Posts: 257
Joined: 2004.06
Post: #1
So I've been doing some work with using the ExtendedAudioFile APIs to do some audio file streaming in conjunction with OpenAL and I've seem to have run into a hitch. The first time a sound plays, it streams fine from the file but the next time I play the sound, I get all sorts of goofy errors. I've tried calling ExtAudioFileSeek to set the file position back to the start of the file but that doesn't seem to work (along with a couple other things that I've tried). So basically my question is has anyone tried this before and if so, how did you get it to work?

I don't have the time to post some code at the moment but I'll see if I can put up a sample project later tonight.

The brains and fingers behind Malarkey Software (plus caretaker of the world's two brattiest felines).
Quote this message in a reply
Member
Posts: 257
Joined: 2004.06
Post: #2
Okay, replying to myself here since I've solved a part of the problem. Namely, I still had some buffers queued when trying to play a sound again. Anyway, I've got a sample project running with this stuff so once I clean it up, I'll host it off my website and people can download it and take a look.

The brains and fingers behind Malarkey Software (plus caretaker of the world's two brattiest felines).
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  What format to use for streaming background music on the iphone? AdrianM 4 4,216 Aug 7, 2009 11:29 AM
Last Post: bware218
  Streaming Audio bmantzey 0 1,626 Mar 3, 2009 03:13 PM
Last Post: bmantzey
  iPhone streaming audio masumbuet 1 1,860 Jan 22, 2009 03:57 PM
Last Post: longjumper