Failing to install dev build to device

Apprentice
Posts: 6
Joined: 2008.11
Post: #1
Hey Everyone,

I could build and run fine, but after installing the iPhone SDK 2.2, xcode can no longer install the build to the phone to test. I searched google and came up with several good pages, but none of them worked exactly for me. I get the error 0xE800003A ApplicationVerificationFailed (two of these boxes pop up each time). The thing is I can build and run it fine the first time, but then every successive time I get this error. After many hours I figured out the magic formula, which seems to be:

1) do a clean all
2) close xcode
3) delete app from iPhone, turn power to the phone off then on again
4) restart xcode
5) alter code etc, then build + go
6) repeat process

As you could imagine..this is extremely frustrating to do EVERY time I want to recompile..and seems to be some sort of error to do with the xcode config, as it does work..but only once... I even created a new App ID and development provisioning profile, but this didnt help.

Here is last part of the output from the Organizer Console from a failed build+go (compiling for Device, Debug):

Tue Dec 30 14:04:28 unknown afcd[210] <Error>: user mobile has uid 501
Tue Dec 30 14:04:28 unknown afcd[210] <Error>: mode is 0x41e8
Tue Dec 30 14:04:33 unknown mobile_installation_proxy[212] <Error>: install_embedded_profile: Skipping the installation of the embedded profile
Tue Dec 30 14:04:34 unknown securityd[204] <Error>: mobile_installat[212] SecItemCopyMatching: missing entitlement
Tue Dec 30 14:04:35 unknown mobile_installation_proxy[212] <Error>: verify_executable: Could not validate signature: e800801
Tue Dec 30 14:04:35 unknown mobile_installation_proxy[212] <Error>: preflight_application_upgrade: Could not verify /var/tmp/install_staging.nMZ42J/EliApp.app/EliApp
Tue Dec 30 14:04:35 unknown mobile_installation_proxy[212] <Error>: upgrade_application: Could not preflight application upgrade
Tue Dec 30 14:04:35 unknown mobile_installation_proxy[212] <Error>: handle_upgrade: Upgrade failed

Any help would be GREATLY appreciated!

Eli
Quote this message in a reply
Member
Posts: 269
Joined: 2005.04
Post: #2
Provisioning is akin to voodoo. Sometimes it just doesn't want to work right. You've tried most of the usual solutions. Also try:

- deleting all the provisioning profiles on the device and reinstalling
- Starting a new project and copying all your code into it
- double-check your Code Signing Identity in *both* Project Info and Target Info
- sacrifice a chicken
- Restore the device from a backup (once this was absolutely the only thing that would work for me)
Quote this message in a reply
Apprentice
Posts: 6
Joined: 2008.11
Post: #3
Hey, thanks for replying... i've tried all you said except sacrificing a chicken Rasp and restoring from backup..which im not too keen to do..only as a super last resort..I really feel the problem must be with xcode..
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  GameKit bluetooth failing on iPad? Cirdan 0 3,735 Sep 3, 2010 01:20 AM
Last Post: Cirdan
  Render to texture failing headkaze 7 7,591 Sep 1, 2010 09:47 PM
Last Post: headkaze
  Multi-touch failing Sumaleth 1 2,615 Feb 24, 2010 08:49 PM
Last Post: Sumaleth
  How to install 2.X SDK bruss14 0 1,628 Jun 24, 2009 08:52 AM
Last Post: bruss14
  OpenAL alGenSources failing captainfreedom 1 3,798 May 26, 2009 07:45 AM
Last Post: captainfreedom