problem running on iPod Touch

Apprentice
Posts: 8
Joined: 2008.10
Post: #1
Hi,
My app runs on iPhone, but not on iPod Touch 1 gen.
It was build for OS2.1 - can this be a reason?
Or do i need to do something else besides making it OS2.0 to run on iPod 1 gen?
Thanks,
Kirill
Quote this message in a reply
Member
Posts: 21
Joined: 2008.06
Post: #2
what firmware do you have in your ipod touch 1st gen ?

are you using the v2.1 exclusive API ?
Quote this message in a reply
Apprentice
Posts: 8
Joined: 2008.10
Post: #3
Here is the situation:
I build my app for OS2.1 in XCode, submitted it to AppStore;
One customer has problems running it on his iPod 1 gen (no details on what is his configuration).

Now, I rebuild it for OS2.0, all runs fine for me here (I do not use anything v2.1 specifics). So, should I submit update now, or is there anything else I can do to take care of this iPod issue?

Generally (unless something OS2.1 exclusive needed), I should always be compiling for OS2.0, right?
Quote this message in a reply
Moderator
Posts: 613
Joined: 2004.09
Post: #4
Apple requires all submissions to be in 2.1 format, they will no longer accept 2.0 code.

Kyle Richter
DragonForged.com
Twitter: @kylerichter
Quote this message in a reply
Moderator
Posts: 335
Joined: 2002.04
Post: #5
One user reporting a crash with no supporting information isn't really enough data to base an update on. It could just be a random crash that has nothing to do with your game.

If the customer is in contact with you, then get as much information out of him as possible before using the data to update, a 2.0 build probably won't fix anything broken in 2.1 as if it is something in your code it's probably just as broken in 2.0.
Quote this message in a reply
Apprentice
Posts: 8
Joined: 2008.10
Post: #6
kodex Wrote:Apple requires all submissions to be in 2.1 format, they will no longer accept 2.0 code.

Are you sure? I see new apps appearing at AppStore for OS2.0 just now.

Also, I just submitted new app build for OS2.0 - it's InReview currently (would expect it to be rejected automatically if they don't accept v2.0 anymore).

So, question is: should I always build for OS2.0 or OS2.1? Are there any guidelines for this? What's the difference if my app does not use anything OS2.1 specific?
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How much can I stuff in to video ram? (on iPhone/iPod touch) Jamie W 9 10,165 Aug 6, 2010 05:23 AM
Last Post: mariocaprino
  Pause/Resume on IPod touch tonysameh 0 2,405 Jul 26, 2010 06:34 AM
Last Post: tonysameh
  iPod Touch not multitasking not working??? Toontingy 1 4,025 Jun 24, 2010 04:13 PM
Last Post: sealfin
  iPhone Only? Not for iPod Touch? daveh84 4 4,261 May 7, 2010 10:46 PM
Last Post: cmiller
  Detecting hardware, which iPhone/iPod I'm running on? Jamie W 9 7,640 Apr 13, 2010 11:27 AM
Last Post: Frank C.