What's wrong with my glutSolidTeapot?

Sage
Posts: 1,199
Joined: 2004.10
Post: #1
Image kind of says it all:

[Image: TeapotSphincter.png]

Admittedly, I don't use glutSolidTeapot very often -- generally just for throwaway stuff -- but I have no idea why my teapot has an apparent sphincter atop the handle.

I have enabled GL_NORMALIZE, and the rest of the teapot looks great. But what's up with the handle? I don't recall this in earlier GLUT teapots...

Wacko

( I'm laying the foundation for the LiSPSM demo I'm going to write, and just wanted something on the screen to make certain my lighting pipeline was sane. )
Quote this message in a reply
Moderator
Posts: 3,571
Joined: 2003.06
Post: #2
LOL teapot sphincter ...

Maybe you could try the glut_teapot out of my shadow mapping demo. I think I pilfered that one from an Apple example.
Quote this message in a reply
Sage
Posts: 1,232
Joined: 2002.10
Post: #3
The normal is 0,0,0 at that point, so the length of the normal is zero. So the normalized normal is...
Quote this message in a reply
Sage
Posts: 1,199
Joined: 2004.10
Post: #4
Well, that certainly explains it, but I don't recall seeing it in the past, and I don't know why the canonical teapot would have a degenerate normal.

Anyway, I'm not using glutSolidTeapot for the LiSPSM demo, so it doesn't really matter. But I was -- and still am -- a little perturbed.
Quote this message in a reply
Sage
Posts: 1,232
Joined: 2002.10
Post: #5
It's always been that way. But, the interpretation of NaN differs depending on the renderer, so it might have looked OK on your old hardware.

If it bugs you, file a radar!.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Lighting a sphere with OpenGL lights (normals wrong?) cecilkorik 3 8,030 Dec 27, 2007 02:40 PM
Last Post: _ibd_
  What could be wrong here? Jones 5 2,788 Jul 1, 2006 08:52 PM
Last Post: Jones
  Can someone help a 'noob'? What's wrong with this? RagingAvatar 7 4,137 Jun 4, 2006 11:54 PM
Last Post: Fenris
  Texture Color is wrong DesertPenguin 7 3,949 Feb 14, 2006 09:04 PM
Last Post: DesertPenguin
  Whats wrong with my collision code? Jake 6 2,931 Sep 11, 2003 12:44 PM
Last Post: MacFiend