SDK problem

Apprentice
Posts: 19
Joined: 2008.05
Post: #1
Hi,

i have a question about osx sdk, i want to target all os x systems and i noticed that some functions are avalible 10.4 and above, does this mean that person running 10.3 will not be able to play my game, if thats the case than how can i check which functions require higher version than 10.2 ?, I had an idea to use old version of sdk but then where i can get it ?
Quote this message in a reply
Member
Posts: 114
Joined: 2005.03
Post: #2
SDKs for down to 10.3.9 should be included with Xcode (you may have to choose to install them), and you can set in your project settings what SDK you want to use. If you use methods that are not available in the selected version, the compiler will tell you.

10.2, I'm not certain whether that is really possible. Maybe someone else knows more. Why do you want to support 10.2 anyway? I got rid of my last computer that shipped with 10.3 earlier this year, so I don't really think that there are still many people with 10.2 around.
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #3
I don't really see the point in targeting 10.2 any more. Even open-source projects dropped 10.2 support a long time ago and most have dropped 10.3 support already.

10.3.9 SDK is an optional install with Xcode 3, 10.2.8 SDK is an optional install with Xcode 2.5.
Quote this message in a reply
Moderator
Posts: 613
Joined: 2004.09
Post: #4
As someone who works in IT and sees a lot of computers coming and going. I can say that targeting 10.3 might even be a waste of time. The people who have 10.3 machines are not out looking for software/shareware. You will be lucky to see 1 out of 1000 downloads on a 10.3 machine.

I see maybe a handful of 10.0 and 10.1 machines a month. Maybe a few dozen 10.3 machines. They are becoming very rare and it would be more work then payoff to support them.
Quote this message in a reply
Apprentice
Posts: 19
Joined: 2008.05
Post: #5
Wow thats nice to hear,

it is possible to make unversal binary that for intel uses 10.4u sdk and for ppc 10.2.8 sdk , for intel gcc4.0 and for ppc gcc3.3, i started doing support for 10.2.8 but the number of functions missing there makes it a bit hard to do it fast. I will talk to my boss about it. It seems that mac users change their system more frequently than windows users ( we are supporting windows 98 - vista for pc version of the game) but for mac i think it will be 10.3 - 10.5+.
I have one more question, if i use sdk 10.3.9 should i use target 10.3 and gcc4.0 ? And if i use sdk 10.3.9 will it work on all 10.3 systems ?
Quote this message in a reply
Apprentice
Posts: 19
Joined: 2008.05
Post: #6
Ow, and one more thing does anyone know a website of some sort that tells how many pll are using legacy versions of os x (10.2 10.3 10.4) ? It would be nice to know.
Quote this message in a reply
Oldtimer
Posts: 834
Joined: 2002.09
Post: #7
http://update.omnigroup.com/ is a pretty good study, and it also mostly shows people who buy software - might be a good thing if you're going to talk to your boss. Smile
Quote this message in a reply
Apprentice
Posts: 19
Joined: 2008.05
Post: #8
I have decided to to support all systems form 10.2, this will be fun...
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #9
I personally believe you are absolutely crazy Rasp

You'll need to build with the Xcode 2.5 tools. Xcode supports building the PowerPC side and the Intel side of the binary with different compilers and different SDKs, but it is not particularly straightforward. If you're used to command-line tools then it may prove easier to build on the command-line than with Xcode.
Quote this message in a reply
Apprentice
Posts: 19
Joined: 2008.05
Post: #10
Ok i must admit that 10.2.8 is very poor when compared to 10.4u, and supporting 10.2 is not the best idea today so i will drop support for it and i reccomed anyone else to do so,
Here is why: 10.4 is already over 3 years old, versions 10.0 -10.3 are already unsupported , ppl who are still using system that is over 3 years old are less likely to buy a game, future support of my framework (the framework handles all platform specific stuff and the game code is platform independent (almost)) will be relay hard if I,m limited to 10.2 calls. Anyways if you considering supporting legacy versions of os X better think twice.
Quote this message in a reply
Apprentice
Posts: 19
Joined: 2008.05
Post: #11
I actually have one more question. If I'm targeting systems 10.4+ than i don't need to distribute OpenAL with the game right ?
Quote this message in a reply
Moderator
Posts: 3,577
Joined: 2003.06
Post: #12
madjerry Wrote:I actually have one more question. If I'm targeting systems 10.4+ than i don't need to distribute OpenAL with the game right ?

Right.

[extra characters for silly forum minimum]
Quote this message in a reply
Post Reply