Problem linking GLSL

Post: #1
I've hardly tried to attach GLSL to my application, but failed to. I am using SDL.
Application builds, but doesn't runs - instead of this I recieve:

Loading program into debugger…
GNU gdb 6.3.50-20050815 (Apple version gdb-768) (Tue Oct 2 04:07:49 UTC 2007)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-apple-darwin".Program loaded.
sharedlibrary apply-load-rules all
Attaching to program: `/Users/Ilya/Game/build/Debug/', process 212.
Xcode: Introspection dylib not loaded because thread 1 has function: __dyld__ZN16ImageLoaderMachO18doModInitFunctionsERKN11ImageLoader11LinkContextE on stack

I suppose, I need to attach dynamic library?

Thank you in advance.
Quote this message in a reply
Posts: 567
Joined: 2004.07
Post: #2
First of all, turn off zerolink.

It's not magic, it's Ruby.
Quote this message in a reply
Posts: 5,143
Joined: 2002.04
Post: #3
That's Leopard's GDB, I don't think he has ZL on... I'm guessing that a dynamic library he has linked already is not where dyld expected it to be, but it's very hard to know without more information.
Quote this message in a reply
Post: #4
Zero link is currently turned off. Still doesn't work.
What information do you need?
Quote this message in a reply
Posts: 5,143
Joined: 2002.04
Post: #5
I'd expect a message to be printed saying what's going wrong (which library dyld can't find, or whatever). Try running the app from Terminal, it might be more helpful than Xcode.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  problem with linking with libjpeg Gecko 2 5,340 Oct 26, 2008 05:40 AM
Last Post: Gecko
  GLSL and multi file linking TomorrowPlusX 4 5,319 Jun 16, 2008 03:48 PM
Last Post: OneSadCookie
  openal linking problem on vc++ express 2005 abousoft 1 5,754 Jan 1, 2007 03:55 AM
Last Post: sealfin
  Linking multiple glsl source files into one program TomorrowPlusX 5 11,032 Nov 2, 2006 02:18 PM
Last Post: OneSadCookie
  Linking problem macboy 2 3,476 Jul 13, 2003 09:08 AM
Last Post: macboy