Quicktime broken?

Sage
Posts: 1,403
Joined: 2005.07
Post: #1
I can't seem to get quicktime to work, I always get these strange linker errors, i'm on Mac OS 10.3.9. Does anyone else get problems like this?

Code:
gcc qttest.c -framework GLUT -framework Cocoa -framework OpenGL -framework Quicktime -framework CoreFoundation -framework Carbon -framework ApplicationServices -o qttest

ld: Undefined symbols:
_HICopyAccessibilityActionDescription referenced from QuickTime expected to be defined in Carbon
_HICopyAccessibilityRoleDescription referenced from QuickTime expected to be defined in Carbon
_LLCStyleInfoCheckForOpenTypeTables referenced from QuickTime expected to be defined in ApplicationServices
_LLCStyleInfoGetUserRunFeatures referenced from QuickTime expected to be defined in ApplicationServices

Sir, e^iπ + 1 = 0, hence God exists; reply!
Quote this message in a reply
Member
Posts: 35
Joined: 2005.01
Post: #2
Yes I have had that problem before. Did you just update your quicktime version? When I upgraded to Quicktime 10.4 I was wondering why I had this problem. It has something to do with the framework linking to OS X 10.4 libraries on a 10.3.9 system. I asked on this forum and it seems like there are two ways to fix it. I think one way is to switch the framework to a previous version, but if you do a search you can probably find out exactly what to switch. The way I fixed this was downgrading QuickTime. I did this from the Apple site which has installers to downgrade your QuickTime version.

Hope this helps,
vbuser
Quote this message in a reply
Oldtimer
Posts: 834
Joined: 2002.09
Post: #3
Try >sudo fixPrecomps in the Terminal. Not very likely to work, but worth a shot nonetheless.
Quote this message in a reply
DoG
Moderator
Posts: 869
Joined: 2003.01
Post: #4
....braaaiiiinnnssss....braaiiiinnnsss...

Seriously, we need to stop creating zombie threads.
Quote this message in a reply
Sage
Posts: 1,066
Joined: 2004.07
Post: #5
I'm hosting the most updated version of the QuickTime framework for 10.3.9 that won't give these errors, AFAIK. This way you can have the newest version of QuickTime and just link to this framework for projects that use SDL or other QuickTime requirements. It's about 4.9Mb so feel free to download it if you need it.
http://www.simrealitystudios.com/dump/Qu...mework.zip
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Is -fconstant-string-class broken under the XCode/Next runtime Justin Brimm 17 7,700 Jun 12, 2008 01:04 PM
Last Post: Justin Brimm
  Is Force Feedback broken in Tiger? Andrew 3 3,538 Aug 23, 2005 03:59 AM
Last Post: Andrew
  is the copy method broken in Tiger? Andrew 7 3,606 May 30, 2005 04:52 AM
Last Post: OneSadCookie