SDK 3.2 breaks support for 2.2.1

Member
Posts: 446
Joined: 2002.09
Post: #16
captainfreedom Wrote:That doesn't make sense. SDK 3.2 doesn't build for OS 2.2.1
Sure it does. As mentioned a few times in this thread already, the official way to support older systems is set the "Base SDK" to the latest version, but set the "Deployment Target" to whatever OS you like - check your project/target build settings...

You just have to be sure to do runtime checks for newer APIs and weak link newer frameworks. As I also mentioned previously, when using a deployment target of 2.x you'll want to build only an arm6 binary (or you won't be able to upload to Apple), and you may need to compile with GCC 4.0 to avoid incompatibilities with the standard libraries on OS 2.x.
Quote this message in a reply
Moderator
Posts: 3,571
Joined: 2003.06
Post: #17
captainfreedom Wrote:Regarding your other point, you guys have made it clear that you don't think anyone uses 2.2.1- and indeed you could be right. However I heard from other sources differently, so I'm just going to play it safe.

"Playing it safe" can be expensive. I'm not saying I don't think anyone uses 2.x; I'm saying I'm not making an effort to develop for 2.x users that won't upgrade their OS for free or five bucks while at the same time I'm trying to keep up with Apple's API and tool updates. It's not worth it unless you're making a hit game (and even then it's questionable). Are you making a hit game? If not, or if you don't know, I wouldn't waste the effort supporting less than 3.x. It's your call of course, but when you've spent two or three weeks supporting 2.x and you get your game out there and it only brings in two or three hundred dollars of revenue a month, is that going to be worth it?
Quote this message in a reply
Member
Posts: 64
Joined: 2008.10
Post: #18
Frank C. Wrote:Sure it does. As mentioned a few times in this thread already, the official way to support older systems is set the "Base SDK" to the latest version, but set the "Deployment Target" to whatever OS you like - check your project/target build settings...

You just have to be sure to do runtime checks for newer APIs and weak link newer frameworks. As I also mentioned previously, when using a deployment target of 2.x you'll want to build only an arm6 binary (or you won't be able to upload to Apple), and you may need to compile with GCC 4.0 to avoid incompatibilities with the standard libraries on OS 2.x.
Ok. thanks very much for the tips!
Quote this message in a reply
Member
Posts: 64
Joined: 2008.10
Post: #19
AnotherJake Wrote:"Playing it safe" can be expensive. I'm not saying I don't think anyone uses 2.x; I'm saying I'm not making an effort to develop for 2.x users that won't upgrade their OS for free or five bucks while at the same time I'm trying to keep up with Apple's API and tool updates. It's not worth it unless you're making a hit game (and even then it's questionable). Are you making a hit game? If not, or if you don't know, I wouldn't waste the effort supporting less than 3.x. It's your call of course, but when you've spent two or three weeks supporting 2.x and you get your game out there and it only brings in two or three hundred dollars of revenue a month, is that going to be worth it?

I have being building against 2.2.1 all along and have had no problems with it. The only extra effort to support it is installing 2 versions of xcode. Isn't that much effort for me.
Quote this message in a reply
Post Reply