new xcode project missing build settings

Member
Posts: 306
Joined: 2009.03
Post: #1
So i started a 2nd project and I noticed that any time I try to use objective c in something that comes from my pch it causes the compiler to crap out.

I think this is because in my original project(which I didn't have this issue) there are a ton more settings in the build info window. One of which is C Dialects to Precompile which has objective-c in there. My question is why would a newer project be missing whole sections here? I created it using the same template, the opengl es one.

In my old project there are entire categories that are not in the new one:
GCC 4.0 - Code Generation(about 15 entries)
GCC 4.0 - Language (about 15 more)
GCC 4.0 - Preprocessing (2)
GCC 4.0 - Warnings(about 20)

Any idea how to get access to more of these in a new project?
Quote this message in a reply
Member
Posts: 245
Joined: 2005.11
Post: #2
When you create a project the compiler defaults to GCC 4.2 and the appropriate settings are shown. If you change the compiler to GCC 4.0 a bunch of stuff should change around accordingly.
Quote this message in a reply
Member
Posts: 111
Joined: 2002.06
Post: #3
The most likely cause is that your new project is set to use a SDK that is not installed on your Mac. Changing the active SDK (Choose Project > Set Active SDK to change it) to a SDK you've installed should make the build settings appear. Read this post from an iPhone development blog for more detailed information.

Mark Szymczyk
http://www.meandmark.com
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #4
It was on 4.0, I changed it to 4.2, both show up in there as installed, but the options are still missing. Everything works so I must have the sdk, but just not seeing these specific gcc settings in the options menu.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Xcode build issue job1984 4 3,754 Sep 3, 2009 08:18 AM
Last Post: job1984
  Xcode gdb SIGTRAP on an OpenGL Project mikey 4 3,774 May 25, 2009 03:39 AM
Last Post: mikey
  CursorDeviceMoveTo() is missing in Carbon Taxxodium 3 3,519 Oct 12, 2002 02:07 PM
Last Post: Tobi