SDL application launching problem

BobbyWatson
Unregistered
 
Post: #1
Hi everyone,

I am currently working on a game. The game uses SDL for OpenGL context creation, event input, and PhysicsFS as the file system. So far, all I have is code to read a file with some settings, and once the settings are read, a window is created with SDL with OpenGL support. Everything seems to be fine, except one little thing :

I can start the application from XCode without problem, it compiles and runs, and exists normally, but it cannot be brought into the foreground. Even though I ask SDL to change the window title, it never shows up in the title window, all I get is a grey bar, as if the windows was still in the background. The application icon does not show up in the dock when the app is running (though I can see it running if i do a ps -aux in the terminal). Also, trying to lauch the application from the Finder by
double clicking on it gives a message saying that the application may be damaged.

I tried cleaning the target and rebuilding everything, but the problem comes back. I checked inside the bundle and I saw that the executable file in Contents/MacOS does not have an icon, I only see it's name. Are these issues related?

Any help would be really appreciated...
Quote this message in a reply
BobbyWatson
Unregistered
 
Post: #2
Never mind, removing the space from the bundle name solves the problem. Sorry about that.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Mac OSX fullscreen application problem e40pud 7 6,156 Mar 12, 2010 05:41 AM
Last Post: OneSadCookie