strange color problem

leggo
Unregistered
 
Post: #1
I have a "spaceship" coloured in shades of green
the problem is that when I enable lighting the colors become light blu, white and green
what could it be?
Quote this message in a reply
Member
Posts: 72
Joined: 2006.10
Post: #2
Screenshots would be really helpfull here. Otherwise, it could be a number of things...

off the top of my head:
- When using lighting, materials are used instead of colors, unless you use GL_COLOR_MATERIAL. Are you setting the materials properly?
- Do your "shades" of green have non-zero green and red channels?

- Sohta
Quote this message in a reply
Member
Posts: 509
Joined: 2002.05
Post: #3
You really didn't tell us anything that could help us solve your problem, it could be hundreds of things. Are you sure your light is white?
Quote this message in a reply
leggo
Unregistered
 
Post: #4
yeah my light is white and I've enabled color material...
sorry for the short post but I'm a little tired Bored

I'd post a screenshot, but I don't know how to take one under osx Blush Blush Blush
Quote this message in a reply
Sage
Posts: 1,066
Joined: 2004.07
Post: #5
Go to the applications folder and then go to utilities. There is a program called grab. Then go up to capture and choose how you want to capture the picture. I personally like just using the selection tool. Don't worry the popup is invisible in the picture so don't worry about moving it.
Quote this message in a reply
leggo
Unregistered
 
Post: #6
tnx! tomorrow I'll post some screens... now I need to slee... ZZZ ZZZ ZZZ ZZZ
Quote this message in a reply
Sage
Posts: 1,232
Joined: 2002.10
Post: #7
You don't have to use Grab. Just press Cmd-Shift-3 to get the whole screen, or Cmd-Shift-4 to get a selection. Or Cmd-Shift-4, space to get a window (does not work with OpenGL content.)

This is documented in the Mac Help, btw.
Quote this message in a reply
Sage
Posts: 1,066
Joined: 2004.07
Post: #8
Oh ok thanks. I didn't even know that. Wait, you said Cmd-Shift-4 twice. Which is which?
Quote this message in a reply
Member
Posts: 72
Joined: 2006.10
Post: #9
The second one is Cmd-Shift-4-space.

- Sohta
Quote this message in a reply
Sage
Posts: 1,066
Joined: 2004.07
Post: #10
Oh I was thrown off by the comma in there.
Quote this message in a reply
leggo
Unregistered
 
Post: #11
without light:
[Image: no-light.jpeg]

with light:
[Image: light.jpeg]



the model is copyrighted, so please don't steal the magnificent model idea or my horde of lawyers will eat you Sneaky
Rasp
Quote this message in a reply
leggo
Unregistered
 
Post: #12
maybe the solution lies here:

I'm importing models from meshwork, so to find a triangle color I divide the color of the material by 65535 (the program uses a 0-65535 scale)
the fact is that the colors I get with the lighting enabled are the same colors I get If I don't divide the colors by 65535 Shock

hope it helps someway Sneaky
Quote this message in a reply
leggo
Unregistered
 
Post: #13
I've resolved switching to wings3d and obj files... now the colors are ok Rasp
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Problem with the graphics color on a videogame for iphone femmedragon 6 5,004 Dec 16, 2012 07:37 PM
Last Post: SethWillits
  ? Find color value of 'pixel' in color buffer? Elphaba 1 4,556 Jul 22, 2009 01:23 PM
Last Post: Bachus
  GLLighting color problem clapton541 4 4,195 May 5, 2007 08:34 PM
Last Post: OneSadCookie
  Strange lighting problem Duncanla 14 6,199 Mar 1, 2005 02:43 PM
Last Post: Duncanla
  Strange SDL problem DJBlufire 4 3,327 Sep 24, 2003 09:09 AM
Last Post: MattDiamond