Xcode Preference to open sourcefile in the editor

Posts: 95
Joined: 2009.09
Post: #1
Hi Guys,

I need help!

After the update to the new version of Xcode I always have to click : "open as"->"Source code file" to open a file in the editor inside the Project Window.

If I just click at the respective file in the "Groups&Files"-Tab or the Detail View it just gets highlighted and not opened. (Editor View says: "No Editor" then)

Before the update Xcode just opened every file the moment I clicked on it and everything was nice.
Now I have to do like 3 clicks to change the opened file in the Editorview in the Project Window.

I'm going crazy here because I can solve any pointer problem in c but can't get the damned xcode to open in one click....
Quote this message in a reply
⌘-R in Chief
Posts: 1,277
Joined: 2002.05
Post: #2
Sounds like Xcode isn't recognizing the file type. Xcode maintains a list of file types and editors (see Preferences). I'd suggest finding that preferences file(s) and removing it and seeing if that helps.
Quote this message in a reply
Posts: 95
Joined: 2009.09
Post: #3
Thank you, that solved my problem.

I removed the File "/Users/*****/Library/Preferences/com.apple.Xcode.plist" and restarted Xcode.
Just needed to reset my old Settings and everything works nice again! Smile
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Texture Editor / Box2D Custom Polygon Editor vladu.bogdan 0 6,975 Feb 9, 2011 07:30 AM
Last Post: vladu.bogdan
  Preference file I/O in Carbon mars 2 4,367 Oct 6, 2005 03:06 AM
Last Post: dair