Anyone using SDL and SMPEG?

DJBlufire
Unregistered
 
Post: #1
I'm using SDL (specifically SDL_mixer) for cross-platform sound, and I'm having trouble getting the music functionality working, especially with SMPEG (for MP3 support). I was wondering if anyone has used SMPEG and SDL in any of their projects, and what they did to get it working.

Thanks!
Quote this message in a reply
Mars_999
Unregistered
 
Post: #2
I would like to help out but I don't have a Mac right now! Mad But when I did I used SDL a lot for my Mac. I never got into the MPEG portion but everything else seemed to work fine in OSX. I guess what is the problem your having?
Quote this message in a reply
DJBlufire
Unregistered
 
Post: #3
I guess it's not really SDL i'm having problems with such much as SDL_mixer, which is a different package, so I dunno if you've run into the problems i'm having or not... I'm just trying to get it to compile with MP3 support.

Anyone had experience with this?
Quote this message in a reply
Mars_999
Unregistered
 
Post: #4
Quote:Originally posted by DJBlufire
I guess it's not really SDL i'm having problems with such much as SDL_mixer, which is a different package, so I dunno if you've run into the problems i'm having or not... I'm just trying to get it to compile with MP3 support.

Anyone had experience with this?


How about a compiler error or code example of what your trying to do?
Quote this message in a reply
DJBlufire
Unregistered
 
Post: #5
No compiler errors or specific pieces of code, except that I know that there's an assertion failiure here:

[SOURCECODE]assert(audio->rawdatawriteoffset > len);[/SOURCECODE]

in the Play_MPEGAudio function.

I had to butcher a lot of the SMPEG source code to get it to compile, so I'm not really surprised that it's not working somehow.

The effect, if i comment that assertion out, is that the MP3 is played in small parts at a time with clicks in between each part.
Quote this message in a reply
wally
Unregistered
 
Post: #6
I have gotten SMPEG to playback MP3 files. I seem to remember that this required removing the ID3 tag from the file.
Quote this message in a reply
DJBlufire
Unregistered
 
Post: #7
Nevermind, I got it to work (and i didn't have to remove the ID3 tag). It turned out that I was compiling the SMPEG and SDL_mixer libraries just fine, but the only problems were from bad frequency/channel/etc. values I was passing to the mixer's init function.

Thanks for all the help though Smile
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  SMPEG on Macintosh parallel 1 2,492 Jul 9, 2005 12:05 PM
Last Post: Skorche
  Sound: SDL_Mixer and SMPEG (mp3's and ogg's) aaronsullivan 5 6,637 Jul 10, 2003 03:47 PM
Last Post: aaronsullivan