what compiler for iPhone OS 3.0?

Member
Posts: 64
Joined: 2008.10
Post: #1
If you want to support iPhone OS 3.0 what compiler should we be using?
previously I was using gcc 4.0, but this now gives build errors w¡th SDK4.
I built with gcc 4.2 and it works on a iOS4 device. I have no idea if it'll break on OS 3.0, because I can't build for those devices anymore.
Quote this message in a reply
Moderator
Posts: 1,560
Joined: 2003.10
Post: #2
gcc 4.2 should work just fine, as far as I know.
Quote this message in a reply
Member
Posts: 446
Joined: 2002.09
Post: #3
Apple appears to be strongly recommending that everyone move to LLVM (or at least LLVM-GCC) as soon as possible. I've had no problems compiling for OS 3.1.3 with LLVM 1.5 but I also have a 3.1.3 device to test on - I wouldn't do it blindly. For what it's worth my last GCC 4.2 builds worked fine on OS 3.1.3 too.
Quote this message in a reply
Nibbie
Posts: 3
Joined: 2010.12
Post: #4
I will also suggest GCC 4.2 it will be good for OS 3.0
Quote this message in a reply
Member
Posts: 446
Joined: 2002.09
Post: #5
Bit of an old thread but I should mention that I've run into problems compiling for iOS 3.x with LLVM 1.6 (in the latest non-beta Xcode). I'd still recommend moving to LLVM sooner rather than later, but LLVM GCC 4.2 is the best you can do if you still need iOS 3.x support.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Issue with the Apple LLVM compiler 3.0... Jamie W 4 4,676 Dec 8, 2011 04:43 PM
Last Post: OneSadCookie
  Accessing the GCC compiler flags Madrayken 6 5,924 Sep 19, 2009 01:18 AM
Last Post: OneSadCookie