Installed iOS 4 SDK, now can't compile for 3 :(

Member
Posts: 21
Joined: 2009.10
Post: #1
Heya! My first post in the new forum! Smile As the title states, I've just installed the iOS 4 SDK in preparation for purchasing an iPhone 4 later this month (and I've been somewhat shocked that all of my uni projects compile and run without error in iOS 4 BlinkWow)... but now I can't compile for iOS 3 (for the iPhone - I can still compile for iOS 3 for the iPad)... Does anybody know how I can regain that ability? Thanks! Smile
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #2
What do you mean, "can't"?

For new app store submissions, you must use the iOS4 SDK, but you may set the deployment target to 3.0 or later, but you should still have [the option to install?] some iOS 3.x SDKs...
Quote this message in a reply
Member
Posts: 269
Joined: 2005.04
Post: #3
The newest SDK (xcode_3.2.3_and_iphone_sdk_4__final.dmg) only includes the iOS 4 and iOS 3.2 SDKs, with no option to install the earlier SDKs. You can still build for 3.0->3.1.3 using the iPhone OS Deployment Target build setting. If you want to actually test your app using those SDKs you have to install the earlier SDK (xcode_3.2.2_and_iphone_sdk_3.2_final.dmg).
Quote this message in a reply
Member
Posts: 21
Joined: 2009.10
Post: #4
Thank you Bachus, that was what I was looking for!
Quote this message in a reply
Post Reply