iPod low upgrade rate to 3.0

Member
Posts: 39
Joined: 2008.10
Post: #1
Hello, Im sure you're all aware of the low transfer rate of iPod touch users over to the 3.0 update.

I recently submitted an update and now the game is only avalible to those with 3.0 installed, this is cutting down sales. I know Rolando 2 has submitted a 2.1 version of their game, does anyone know how you go about doing this?

Thanks for any help
Quote this message in a reply
Member
Posts: 86
Joined: 2008.04
Post: #2
You need to build with an older version of XCode and select the earlier 2.2.1 SDK.

(And still test the app by running it on a 3.0 device )
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #3
You can build for 2.X with the latest xcode... thats what I did.
Quote this message in a reply
Member
Posts: 39
Joined: 2008.10
Post: #4
Thanks a lot guys, good to hear that its so simple.

This isnt the case for now but if i were to add 3.0 features to a future game is it possible to have both versions or will it cut me out of the 2.X market?
Quote this message in a reply
Member
Posts: 50
Joined: 2008.06
Post: #5
You can weakly reference (I think there's some other name) the 3.0 framework and then directly use the 2.x. Then test if they can perform the 3.0 features and only use them if they can. There are tutorials posted (somewhere, I don't recall) that show how to do it.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Frame rate issues markhula 7 6,285 Jan 15, 2011 09:47 AM
Last Post: markhula
  Frame Rate Consistency daveh84 4 3,485 May 4, 2010 12:19 PM
Last Post: AnotherJake
  limiting frame rate NelsonMandella 14 5,715 Sep 16, 2009 02:57 PM
Last Post: bmantzey
  frame rate for a Quartz game? aerospaceman 2 3,851 Jun 22, 2009 10:56 AM
Last Post: longjumper
  mac mini simulator - slow frame rate sumiguchi 3 3,704 Dec 18, 2008 08:56 AM
Last Post: SafariAl