Tricky bug

Member
Posts: 117
Joined: 2010.09
Post: #1
Hi all,

Not had this bug before ; so assume it's me but can't trace it. Have upgraded to Lion and latest Xcode 4.
Basically a texture seems to have it's UV's wrong but only on almost every other download to the simulator.
i.e. I can download and it's fine, then not, then fine, then not etc. - without recompiling or anything.

I've sat in the debugger checking things but can see nothing wrong. The texture seems correct but the uv's seem wrong. Only seems to happen on this one and only texture.

It's tricky!, wondering if somehow there's something I can use perhaps in instruments or maybe new in Xcode 4 to help me isolate this annoying thing :-)

Any help appreciated

Cheers
EDIT: Have forced this one texture to always have the same frame. The uv's (using printf's) are correct all the time i.e. when the texture is drawn correctly or not!; can't see what else could cause this....

EDIT 2:
Ok this is ultra weird!
I now the display the entire questionable texture on screen.
Every other time it is perfect, the alternative time's it's completely different!!! - and I am not doing any processing on the texture!!! - erk!!!. Is it possible wonderful Xcode 4 is 'pre-processing' it somehow (for what reason?) and altering it!!!?!!!!!!!!!!!!!!!!!!

EDIT 3:
Can confirm that although PNG compression is off; something is altering my png (not an icon, but in game texture). Ever since Xcode 4 upgrade. Wow, serious bug!!!. Can't try on device yet so it could just be a simulator 'thing'. Have googled and can't see anyone else with a similar problem!!!
Quote this message in a reply
Moderator
Posts: 434
Joined: 2002.09
Post: #2
Would be good to isolate whether it is loaded incorrectly right off the bat, or if instead it gets corrupted later.

Measure twice, cut once, curse three or four times.
Quote this message in a reply
Luminary
Posts: 5,143
Joined: 2002.04
Post: #3
Xcode has always mangled PNGs when building for iOS... it's possible to disable it, but it doesn't seem to explain your alternating good/bad behavior.
Quote this message in a reply
Member
Posts: 117
Joined: 2010.09
Post: #4
It's well weird.

If I change the texture i.e. make it completely different. Then it will alternate on each download between the correct texture and some old/corrupt image (i.e. nothing like the original texture).
Does suggest Xcode has a temp file somewhere with this in, and is picking it up - though why it should alternate is beyond me.
Have logged the bug with Apple - just wondered if I was the only one in the world with this issue!!

Cheers
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Many questions tonight. Tricky inheritance issue kendric 0 1,982 Mar 9, 2009 08:40 PM
Last Post: kendric