3.0 crashes

Member
Posts: 306
Joined: 2009.03
Post: #1
I upgraded my touch to 3.0 last night and in some last minute testing before releasing my app I have had 2 random total ipod lockups. Had to hold both buttons to reboot. I have spent vast # of hours testing on 2.x but not on 3.x. The game logic is very solid and stable as I havent had a crash on 2.x in a long time. The fact that this seems to be completly random(one was during a dialog popup that didnt have anything going on, the other was during gameplay) is worriesome. Has anyone seen something like this? I probably will have to postpone my release to do more testing Sad. Note that the app has been built and tested under 2.x sdk for a while. So its not an SDK change, just an iphone OS update.
Quote this message in a reply
Member
Posts: 50
Joined: 2008.06
Post: #2
I've noticed that 3.0 is much pickier on over releasing and such that 2.x just seemed to kind of go with at times. Not sure about hanging, but 3.0 apps seem more likely to crash on incorrectly released or used items.
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #3
I had another one and after a while it finally unhung and dumped to main screen. No crash report was generated though. Does anyone know things that can cause that? Infact I just got it again right now... After about 60 seconds it quits.

The oddest thing is I cannot get this to happen in debug mode. Maybe i just didnt play for long enough. I have had it happen 4 times when not in debug mode.

In the console I see the following but I am guessing this is regular startup stuff. It appears after the ipod vanishes from navigator and reappears when the ipod recovers itself

==== Attached at 2009-07-20 17:42:37 -0500 ====
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: 5 out, EPs: 5, max_endpoint: 7, num_endpoints: 12
Mon Jul 20 17:41:42 unknown com.apple.launchd[1] <Notice>: *** launchd[1] has started up. ***
Mon Jul 20 17:41:48 unknown com.apple.launchd[1] <Warning>: (com.apple.BTServer) open("/var/logs/BTServer/stdout", ...): No such file or directory
Mon Jul 20 17:41:48 unknown com.apple.launchd[1] <Warning>: (com.apple.BTServer) open("/var/logs/BTServer/stderr", ...): No such file or directory
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleSynopsysOTGCore::start - iAP over USB enabled
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: read new style signature 0x43313133 (line:305)
Mon Jul 20 17:41:48 unknown /usr/sbin/fairplayd[19] <Notice>: Vroum
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: [FTL:MSG] VSVFL Register [OK]
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: [FTL:MSG] VFL Init [OK]
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleS5L8720XFMSS::_fmssInitCmdsAndCEMaskCtrl: VendorSpecific: VS_CMD_ONFI_2D
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleS5L8720XFMSS::_fmssInitCmdsAndCEMaskCtrl: VendorSpecific: VS_CMD_ONFI_2D
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: [FTL:MSG] VFL_Open [OK]
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: [FTL:MSG] YAFTL Register [OK]
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: BCMWLAN Firmware Version: wl0: May 16 2009 18:05:35 version 4.216.64.18
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMultitouchZ2SPI: detected HBPP. driver will be kept alive
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: yaFTL::YAFTL_Open(l:2738): CXT is not valid . Performing full NAND R/O restore ...
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleD1759PMUPowerSource: AppleUSBCableDetect 1
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::handleUSBCableConnect cable connected, but don't have device configuration yet
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMBX: Added swap device: AppleM2TVOut id: c0b3ec00
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleBCMWLAN::initFirmware(): successful initialization
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleBCMWLAN: Ethernet address 00:23Grinf:e7:00:09
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleBCMWLAN::setPowerStateGated() : Powering On
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMultitouchZ2SPI: downloaded 128 bytes of prox calibration data ("built-in")
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMultitouchZ2SPI: downloaded 256 bytes of calibration data ("built-in")
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AirPort: Link Down on en0
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMultitouchZ2SPI: downloaded 48612 bytes of firmware data ("0x0051.bin") in 150ms.
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: AppleMultitouchZ2SPI: enabled power, scheduled bootloading
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: [FTL:MSG] FTL_Open [OK]
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: Got boot device = IOService:/AppleARMPE/arm-io/AppleS5L8720XIO/flash-controller0@A00000/AppleS5L8720XFMSS/disk@FF/AppleNANDFTL/IOFlashBlockDevice/IOBlockStorageDriver/unknown vendor unknown product Media/IOFDiskPartitionScheme/Untitled 1@1
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: BSD root: disk0s1, major 14, minor 1
Mon Jul 20 17:41:48 unknown /System/Library/CoreServices/DumpPanic[25] <Error>: Failed to connect to lockdown. Attempt 1 of 10
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: L2TP domain init
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: L2TP domain init complete
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: PPTP domain init
Mon Jul 20 17:41:48 unknown kernel[0] <Debug>: Jettisoning kext bootstrap segment.
Mon Jul 20 17:41:48 unknown mDNSResponder[16] <Error>: mDNSResponder mDNSResponder-191.9 (May 13 2009 22:49:14) starting
Mon Jul 20 17:41:48 unknown /usr/bin/IQAgent[18] <Notice>: Unsupported. Exiting.
Mon Jul 20 17:41:49 unknown kernel[0] <Debug>: mDNSResponder[16] syscall_builtin_profile: mDNSResponder (seatbelt)
Mon Jul 20 17:41:49 unknown kernel[0] <Debug>: mDNSResponder[16] Builtin profile: mDNSResponder (seatbelt)
Mon Jul 20 17:41:49 unknown kernel[0] <Debug>: systemShutdown false
Mon Jul 20 17:41:49 unknown com.apple.BTServer[28] <Notice>: BTServer 1.2 () Modified on
Mon Jul 20 17:41:49 unknown com.apple.BTServer[28] <Notice>: com.apple.server.bluetooth: Bluetooth Super Server Robot Destroyer
Mon Jul 20 17:41:49 unknown com.apple.BTServer[28] <Notice>: com.apple.server.bluetooth: Got local-mac-address: 00:23Grinf:ef:41:5c
Mon Jul 20 17:41:49 unknown com.apple.BTServer[28] <Notice>: machport is com.apple.server.bluetooth
Mon Jul 20 17:41:49 unknown lockdownd[14] <Error>: (0x39d802b8) _lookup_imei: Could not get matching service for baseband
Mon Jul 20 17:41:49 unknown /usr/libexec/CrashHousekeeping[26] <Error>: Failed to connect to lockdown. Attempt 1 of 10
Mon Jul 20 17:41:49 unknown mDNSResponder[16] <Error>: Note: SetDomainSecrets: no keychain support
Mon Jul 20 17:41:49 unknown mediaserverd[15] <Error>: Failed to connect to lockdown. Attempt 1 of 10
Mon Jul 20 17:41:49 unknown configd[20] <Notice>: skipped com.apple.SystemConfiguration.PowerManagement (excluded)
Mon Jul 20 17:41:49 unknown /System/Library/CoreServices/DumpPanic[25] <Error>: Failed to connect to lockdown. Attempt 2 of 10
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Running /etc/bluetool/iPod2,1.boot.script.
Mon Jul 20 17:41:50 unknown mDNSResponder[16] <Error>: HW_MODEL: Device (Device) Portability 99 Marginal Power 99 Total Power 99
Mon Jul 20 17:41:50 unknown mDNSResponder[16] <Error>: D2DInitialize!!!
Mon Jul 20 17:41:50 unknown mDNSResponder[16] <Error>: CFRunLoop member is active
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Cannot read termcap database;
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: using dumb terminal settings.
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Opening com.apple.uart.bluetooth @ 115200 baud.
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: bluetooth wake is now ON
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: bluetooth reset was pulsed 100 ms
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Issued HCI Reset
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: DeviceTree speed = 3000000
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Sending Update_UART_Baud_Rate
Mon Jul 20 17:41:50 unknown com.apple.BTServer[28] <Notice>: Setting local baud rate
Mon Jul 20 17:41:50 unknown /usr/libexec/CrashHousekeeping[26] <Error>: Failed to connect to lockdown. Attempt 2 of 10
Mon Jul 20 17:41:50 unknown configd[20] <Notice>: CLTM: No thermal sensors detected, not registering for notifications
Mon Jul 20 17:41:50 unknown mediaserverd[15] <Error>: Failed to connect to lockdown. Attempt 2 of 10
Mon Jul 20 17:41:50 unknown /System/Library/CoreServices/DumpPanic[25] <Error>: Failed to connect to lockdown. Attempt 3 of 10
Mon Jul 20 17:41:51 unknown /usr/libexec/CrashHousekeeping[26] <Error>: Failed to connect to lockdown. Attempt 3 of 10
Mon Jul 20 17:41:51 unknown mediaserverd[15] <Error>: Failed to connect to lockdown. Attempt 3 of 10
Mon Jul 20 17:41:51 unknown /System/Library/CoreServices/DumpPanic[25] <Error>: Failed to connect to lockdown. Attempt 4 of 10
Mon Jul 20 17:41:52 unknown /usr/libexec/CrashHousekeeping[26] <Error>: Failed to connect to lockdown. Attempt 4 of 10
Mon Jul 20 17:41:52 unknown mediaserverd[15] <Error>: Failed to connect to lockdown. Attempt 4 of 10
Mon Jul 20 17:41:52 unknown /System/Library/CoreServices/DumpPanic[25] <Error>: Failed to connect to lockdown. Attempt 5 of 10
Mon Jul 20 17:41:53 unknown configd[20] <Error>: Failed to connect to lockdown. Attempt 1 of 10
Mon Jul 20 17:41:53 unknown /usr/libexec/CrashHousekeeping[26] <Error>: Failed to connect to lockdown. Attempt 5 of 10
Mon Jul 20 17:41:53 unknown DumpPanic[25] <Notice>: Panic data written to /Library/Logs/CrashReporter/Panics/2009-07-20-174149.panic.plist
Mon Jul 20 17:41:55 unknown SpringBoard[23] <Error>: WiFi: Consulting "no-sdio-devices" property.
Mon Jul 20 17:41:55 unknown SpringBoard[23] <Error>: WiFi: "no-sdio-devices" property not found.
Mon Jul 20 17:41:55 unknown kernel[0] <Debug>: AirPort: Enabled AppleBCMWLAN (link 1, sys 0, user 1)
Mon Jul 20 17:41:55 unknown configd[20] <Notice>: network configuration changed.
Mon Jul 20 17:41:55 unknown configd[20] <Notice>: setting hostname to "Tom-Delorenzis-iPod"
Mon Jul 20 17:41:55 unknown lockdownd[14] <Error>: (0x80d600) _load_system_version: Could not lookup release type
Mon Jul 20 17:41:56 unknown SpringBoard[23] <Warning>: lockdown says the device is: [Activated], state is 3
Mon Jul 20 17:41:57 unknown lockbot[37] <Error>: copy_preference: Could not lookup key SBFormattedPhoneNumber
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) lockbot_copy_preference: lockbot returned an error: MissingPreferenceValue
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) load_activation_records: looking at /var/root/Library/Lockdown/activation_records (1/0)
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) load_activation_records: looking at /var/root/Library/Lockdown/activation_records/pod_record.plist (8/0)
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) _extract_record_identifier: Could not extract ICCID from account token
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) load_activation_records: Could not extract ICCID from record
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) load_activation_records: This is the iPod activation record
Mon Jul 20 17:41:57 unknown lockdownd[14] <Error>: (0x80d600) load_activation_records: looking at /var/root/Library/Lockdown/activation_records (6/0)
Mon Jul 20 17:41:58 unknown lockdownd[14] <Error>: (0x80d600) determine_activation_state: The original activation state is Activated
Mon Jul 20 17:41:58 unknown lockdownd[14] <Error>: (0x80d600) determine_activation_state: SIM status: kCTSIMSupportSIMStatusReady
Mon Jul 20 17:41:58 unknown lockdownd[14] <Error>: (0x80d600) determine_activation_state: The activation state has not changed.
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice - Configuration: PTP
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: PTP
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice - Configuration: iPod USB Interface
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: USBAudioControl
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: USBAudioStreaming
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: IapOverUsbHid
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice - Configuration: PTP + Apple Mobile Device
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: PTP
Mon Jul 20 17:41:58 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice Interface: AppleUSBMux
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction Register function USBAudioControl
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: IOAccessoryPortUSB::start
Mon Jul 20 17:41:59 unknown /usr/libexec/ptpd[12] <Notice>: PTP interface bas been activated at high speed.
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction Register function IapOverUsbHid
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: virtual bool AppleUSBDeviceMux::start(IOService*) build: May 13 2009 22:35:22
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: init_waste
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction Register function AppleUSBMux
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction Register function USBAudioStreaming
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction Register function PTP
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::gated_registerFunction all functions registered- we are ready to start usb stack
Mon Jul 20 17:41:59 unknown kernel[0] <Debug>: AppleSynopsysOTGDevice::handleUSBReset
Mon Jul 20 17:41:59 unknown com.apple.BTServer[28] <Notice>: HANG: Waited 10 seconds for BlueTool to run boot.script
Mon Jul 20 17:41:59 unknown MobileBluetooth[28] <Notice>: Ok.... init failed we are in high power ... relaunch !
Mon Jul 20 17:41:59 unknown com.apple.launchd[1] <Warning>: (com.apple.BTServer) Exited with exit code: 1
Mon Jul 20 17:41:59 unknown com.apple.launchd[1] <Warning>: (com.apple.BTServer) open("/var/logs/BTServer/stdout", ...): No such file or directory
Mon Jul 20 17:41:59 unknown com.apple.launchd[1] <Warning>: (com.apple.BTServer) open("/var/logs/BTServer/stderr", ...): No such file or directory
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: BTServer 1.2 () Modified on
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: com.apple.server.bluetooth: Bluetooth Super Server Robot Destroyer
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: com.apple.server.bluetooth: Got local-mac-address: 00:23Grinf:ef:41:5c
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: machport is com.apple.server.bluetooth
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Running /etc/bluetool/iPod2,1.boot.script.
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Cannot read termcap database;
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: using dumb terminal settings.
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Opening com.apple.uart.bluetooth @ 115200 baud.
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: bluetooth wake is now ON
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: bluetooth reset was pulsed 100 ms
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Issued HCI Reset
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: DeviceTree speed = 3000000
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Sending Update_UART_Baud_Rate
Mon Jul 20 17:42:00 unknown com.apple.BTServer[38] <Notice>: Setting local baud rate
Mon Jul 20 17:42:02 unknown lockdownd[14] <Error>: (0x80e400) calculate_application_usage: Could not lookup the previous mobile application usage
Mon Jul 20 17:42:04 unknown SpringBoard[23] <Error>: WiFi: Consulting "no-sdio-devices" property.
Mon Jul 20 17:42:04 unknown SpringBoard[23] <Error>: WiFi: "no-sdio-devices" property not found.
Mon Jul 20 17:42:07 unknown profileInstallationHelper[32] <Warning>: loading file /var/mobile/Library/Carrier Bundle.bundle/profile.mobileconfig inspection: 0
Mon Jul 20 17:42:07 unknown profileInstallationHelper[32] <Warning>: -[MCPayloadManager setupWithPayloadFile:forInspection:] 2118 : could not set up from file /var/mobile/Library/Carrier Bundle.bundle/profile.mobileconfig
Mon Jul 20 17:42:07 unknown profileInstallationHelper[32] <Warning>: /SourceCache/ManagedConfiguration/ManagedConfiguration-302.2/MCPayloadManager.m 2119 : Error Domain=MCPayloadHandlerErrorDomain Code=1 UserInfo=0x1114b0 "Profile could not be validated" {
Class = MCPayloadManager;
MCErrorType = MCFatalError;
Method = "setupWithPayloadFile:forInspection:";
NSLocalizedDescription = "Profile could not be validated";
NSLocalizedRecoveryOptions = (
OK
);
NSLocalizedRecoverySuggestion = "Profile could not be read.";
}
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Current Device: UART - com.apple.uart.bluetooth
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Setting speed to 115200
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: DeviceTree speed = 3000000
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Sending Update_UART_Baud_Rate
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Setting local baud rate
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Using env variable: BT_DEVICE_ADDRESS = 00:23Grinf:ef:41:5c
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Sending Write_BD_ADDR
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Using host name: Tom-Delorenzis-iPod
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Sending Write_Local_Name: Tom-Delorenzis-iPod
Mon Jul 20 17:42:09 unknown com.apple.BTServer[38] <Notice>: Sending Set_Sleepmode_Param
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: com.apple.server.bluetooth: Server attached, going into msg loop.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Running /etc/bluetool/iPod2,1.init.script.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Cannot read termcap database;
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: using dumb terminal settings.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Running /etc/bluetool/iPod2,1.deepsleep.script.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Cannot read termcap database;
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: using dumb terminal settings.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: DeviceTree speed = 3000000
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Opening com.apple.uart.bluetooth @ 3000000 baud.
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: bluetooth wake is now ON
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Issued HCI Reset
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: Sending Set_Sleepmode_Param
Mon Jul 20 17:42:10 unknown com.apple.BTServer[38] <Notice>: bluetooth wake is now OFF
Mon Jul 20 17:42:10 unknown lockbot[68] <Error>: copy_preference: Could not lookup key SBFormattedPhoneNumber
Mon Jul 20 17:42:10 unknown lockdownd[14] <Error>: (0x39d802b8) lockbot_copy_preference: lockbot returned an error: MissingPreferenceValue
Mon Jul 20 17:42:10 unknown /System/Library/CoreServices/SpringBoard.app/SpringBoard[23] <Notice>: CLTM: initial thermal level is 0
Mon Jul 20 17:42:13 unknown SpringBoard[23] <Warning>: BTM: BTLocalDeviceGetPairedDevices returned 0 devices
Mon Jul 20 17:42:13 unknown SpringBoard[23] <Warning>: SB SYNC: iTunesSyncRequestedStart 0
Mon Jul 20 17:42:13 unknown SpringBoard[23] <Warning>: SB SYNC: beginSyncing 1
Mon Jul 20 17:42:13 unknown SpringBoard[23] <Warning>: SB SYNC: didShowSyncPanel 2
Mon Jul 20 17:42:13 unknown SpringBoard[23] <Warning>: SB SYNC: _notifyAppsSyncWillBegin 2
Mon Jul 20 17:42:14 unknown BackupAgent[73] <Warning>: Backup session starting
Mon Jul 20 17:42:17 unknown SpringBoard[23] <Warning>: SB SYNC: iTunesSyncHasCompleted 2
Mon Jul 20 17:42:17 unknown SpringBoard[23] <Warning>: SB SYNC: didEndSyncing 5
Mon Jul 20 17:42:17 unknown SpringBoard[23] <Warning>: ITDBPrepServerPostProcessRun: [BEGIN] looking up itdbprepserver.
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: starting up.
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: acquired iTunes sync file lock.
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: acquired itdbprep file lock.
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: posting com.apple.itdbprep.notification.willBegin
Mon Jul 20 17:42:18 unknown SpringBoard[23] <Warning>: ITDBPrepServerPostProcessRun: [-END-] looking up itdbprepserver. success = 1
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: BEGIN processing command: com.apple.itdprep.command.runPostProcess
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: [BEGIN] Post Processing...
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: Skipping iTunes Commands.
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: Running Misc Commands...
Mon Jul 20 17:42:18 unknown itdbprepserver[78] <Warning>: Running Sorting Process...
Mon Jul 20 17:42:19 unknown itdbprepserver[78] <Warning>: Running Create Triggers...
Mon Jul 20 17:42:19 unknown itdbprepserver[78] <Warning>: [-END-] Post Processing.
Stats
totalTime=0.55s
commands=0.02
misc=0.05s
icuSort=0.47s (MLS_icu_data=0.01s, MLS_icu_sec_data=0.00, dropIdx=0.16, normalize=0.04, update_orders=0.02, tStatsICUOther1=0.01, createIndex=0.22)
Mon Jul 20 17:42:19 unknown itdbprepserver[78] <Warning>: *** STARTING: DB Backup (CREATE-NEW) ***
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #4
Also of note is while my game is running and this crash happens, the only things that are common are sound and render code. While the game is running i see these pop up in the console randomly

Mon Jul 20 17:44:52 unknown mediaserverd[15] <Error>: [17:44:52.614 <AudioQueueServer>] AudioQueueObject::IONodeConnection::_AcquireHardwareCodec: failed ('hwiu')
Mon Jul 20 17:44:52 unknown mediaserverd[15] <Error>: [17:44:52.625 <AudioQueueServer>] Prime failed ('hwiu'); will stop (5512/0 frames)

But a crash doesn't happen immiedatly after. Could be related but not sure what ot make of that. I will play for a long while without sound and see what happens.
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #5
A minor update. I played for about 1-2 hours with all sound commented out and no issues. Then i enabled all wavs, i didn't get to play that long but I noticed no errors in the console. When I enabled all the mp3s the errors came back. I am thinking it doesn't like my mp3s for some reason. I will post again if I find more.
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #6
I still get that error only when an mp3 (or even an m4a aac) is used. If anyone can check if they see that on their console when they use mp3s that would be very heflpfull.
Here is the exact text. I get one per mp3. Just to clarify I hear the music just fine.
Code:
Mon Jul 20 21:00:50 unknown mediaserverd[15] <Error>: [19:00:50.279 <AudioQueueServer>] AudioQueueObject::IONodeConnection::_AcquireHardwareCodec: failed ('hwiu')
Mon Jul 20 21:00:50 unknown mediaserverd[15] <Error>: [19:00:50.284 <AudioQueueServer>] Prime failed ('hwiu'); will stop (11025/0 frames)
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #7
I was able to get rid of that error by making sure that no 2 mp3s are loaded ever at the same time. I guess ill play my game for a good long time now and see if the other problem went away. Fingers crossed.
Quote this message in a reply
Member
Posts: 269
Joined: 2005.04
Post: #8
kendric Wrote:I was able to get rid of that error by making sure that no 2 mp3s are loaded ever at the same time. I guess ill play my game for a good long time now and see if the other problem went away. Fingers crossed.

The iPhone uses a specialized hardware chip for MP3 and AAC decoding/playback. It tends to choke and freeze the system if more than one music file is played at a time. I haven't tested that explicitly under 3.0 to see if that is still the case, but it was a pretty serious issue with 2.x. Especially with early versions of 2.x where you couldn't know if the iPod was playing when your app launched.

So yea, don't play two MP3s at a time. Wink
Quote this message in a reply
Member
Posts: 306
Joined: 2009.03
Post: #9
Like I said, they weren't playing, just loaded. I clocked a good 30 hours playing under 2.x and never had this lock up. I was in debug mode for most of that though and I only have had this happen during regular play. Go figure. So far so good though.
Quote this message in a reply
Post Reply 

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  app crashes in non-debug environment Gillissie 2 2,984 Dec 12, 2009 05:03 PM
Last Post: DoG